farmerswife

Welcome
Login  Sign up

Projects Tree

Through the Project Tree it is possible to create and view Projects in a Giant style chart.
The basic Project Structure consists of the Project, the Project Bookings and the booked Objects.
Projects can be further organised with Containers and Binders. The Container contains Projects that belong to each other.
The Binder is found at a level below the Project and can be used as a way to group Bookings that belong to each other, e.g. if they belong to the same episode, or the same phase e.g. post production. Binders can be created in two levels; Binder and Sub Binder.

In the Projects tree structure all these levels can be viewed as each level is expanded.
The Object is at the lowest level, and in case an Object is booked as an Accessory this will be the very last level of the Projects Tree, the point is to visually show that it was booked as an Accessory.
It is also possible to track and set Markers as milestones, create dependencies between Bookings, and save Booking Templates. All this will be explained in the following sections.

  1. Add Projects To Tree
  2. Project Menu
  3. Project Structure: Sort & Order
  4. Booking Operations
  5. Binders
  6. Relations/ Dependancies
  7. Frameworks
  8. Booking Templates


There are various ways in which Projects can be added to the Projects Tree

  • Drag and drop from the Toolbox > Projects tab
  • Projects Tree Menu Options
  • Projects Tab - Advanced Search

Drag and drop from the Toolbox > Projects tab

Load one or more Projects into the Project Tree by dragging them from the Toolbox > Projects tab and dropping them when the word Project lights up in green (drag onto the name Projects).


To add another Project to the Tree, drag and hover the cursor over the name of an already loaded Project, to drop above or below depending on the direction the blue arrow is pointing.


Add via Projects Tree Menu

To view the Projects Tree Menu click on the Projects Tree Icon. There are four options in the main menu to add Projects to the Tree; Add Project, Add Project By Client, Add Project Other and Auto From Viewport / Calendar


  1. Add Project - Displays the list of Projects by name. If containers are used to group the Projects these will appear at the bottom of the list.
  2. Add Project By Client - Displays the list of Projects filtered by Client.
  3. Add Project Other. Two options are available:
  • New: Use this to create a new project
  • AutoFrom View Port/ Calendar: The Project Tree will be populated with Projects that have Bookings within the time range that is defined in the pop up View Port calendar.
    Below the calendar there are a number of check boxes to further specify what Projects should be added to the Projects Tree, i.e. to add Projects that start and/or end within the selected time range. When selecting dates in this calendar the time frame displayed in the Long Form will generally not change unless you select the last option "Set Viewport to Range". e.g.


Auto From View Port Calendar

The last option in the Projects Tree Menu "Auto From Viewport / Calenader" is related to the View Port on the right hand side above the Long Form. Not to be confused with the previously described option found under Add Project Other. When this filter is selected the Projects Tree will be populated with Projects that have Bookings within the selected time period. The Projects will be listed in alphabetical order. If the time period in the View Port is changed the Projects populating the Projects Tree will change accordingly. When new Bookings are made on existing or new Projects within the selected time frame, the Project will automatically be added to the Project Tree. This feature also respects the settings in WIFE Client > Toolbox > Projects > dropdown menu: "Show Only Projects Where I Have Write Permissions" and "Show Only My Projects". The option does not work if the View Port was previously set to Auto.

Add Project to tree via Projects Tab Advanced Search

To add a selection of Projects to the Projects tree it is possible to search in the Advanced Projects Search under the Projects Tab in the top navigation bar. In the example a search has been made on the Custom Field "Project Type" and on the value Commercial. Highlight the Projects that should be added to the tree (on PC ctrl click on Mac cmd click to make selection). Click on the drop down menu button or right-mouse click to show the menu. Click on "Add To Tree (Selection x). Go back to the Long Form view to find the selected Projects in the Tree.


2. Project Menu

Click on the Project Icon to bring up the Project Menu.

  • Edit - Opens the Edit Project window.

  • Edit Client - Opens the Edit Client window.

  • Solo View - Removes all other Projects from the Projects Tree.

  • Remove From View - Removes this Project from the Projects Tree.

  • Show All Involved In Objects Tree - Displays all Objects involved in the Project in the Objects Tree.

  • Show All Involved In Personnel Tree - Displays all Users involved in the Project in the Personnel Tree.

  • Show All Involved In Hourline Tree - Displays all Objects involved in the Project in the Hourline.

  • Show Conflicts - Brings Up the Conflicts Window to view any Conflicts.

  • Web View Limits - To determine what, when and by whom Projects can be viewed in the Web Client and the iOS farmeswife app. If a certain Project should not yet be viewable for Web Users un-tick the checkbox "Allow Web Viewing". In Date and Out Date define the time period in which Web Users can access the Project related information, it is possible to select only In Date or Out Date. Click on the Icon and the Calendar will pop up. If "Filter By Web User" is ticked the involved Users will be listed and the selected Users will get access. If no User is selected all will have access during the defined time period. If "Filter Objects" is ticked all the involved Objects will be listed. The Objects selected will be viewable for Web Users, if none is ticked all Objects will be available.


  • Set Static Time Frame From Time Range -The project Time Frame is usually determined by the dates of the Project Bookings, but with this option it is possible to set the Project Time Frame to a fixed number of days. Select the time range by dragging from the desired start to end date on the Long Form view (days will be marked yellow) and then select the option Set Static Time Frame From Time Range.

  • Remove Static Time Frame - Removes the Static Time Frame from a Project.

  • Move Start Day From Calendar - Moves the Project start date to a date selected in the pop up calendar. This will change the date of the first Booking and ripple any subsequent Bookings accordingly.

  • Move Stop Day From Calendar - Moves the Project Stop date to a date selected in the pop up calendar. This will change the date of the last Booking and ripple any prior Bookings accordingly.

    *Moving start or stop date could lead to that weekends and public holidays are booked.

  • Force Colour - Changes the Colour of the Project overriding the Client colour.

  • New Marker - Creates a New Marker. A Marker is a deadline or a milestone and is used to display certain significant dates within a Project in the Projects Tree.

Click on New Marker > Select the Date > Select the Time > Select the Name, Colour and Note for the Marker. The marker is displayed as a red triangle ranging from the top to the bottom of the Project. Mouse over to see the details of the Marker. To Edit the Name, Colour and Note, Change the Time And Date, modify the Checkpoint status, or Remove the Marker click on the Top or Bottom triangle or anywhere along the stem to display the menu. To change the size of the Marker go to Toolbox > Settings > Project Tree and tick / un-tick the checkbox "Small Markers"

Default Marker Names and related custom fields can be created in Toolbox > Settings > Binder/Marker Defaults. Click on the tab next to Marker / Defaults > Name / Colours. Type in Name and select Colour of the Marker. For Custom fields click on the Custom Fields icon.

  • Container - To Edit, Add or Detach the Project to/from a Container.

3. Project Structure: Sort & Order.


farmerswife allows you to organise your projects in a very straight forward structure so you can have an overview just with a glance. Below you can see the different options you can use.

Display Project Number and Name

The default order is to display the Project name and the Project Number within brackets.
To display in the order of Number / Name go to the Toolbox > Miscellaneous and select Display Number / Name

Sort Projects in the Tree

It is possible to sort either alphabetically or by project number. To sort click on the Project Tree icon and in the menu find the sort options A-Z or Sort By Project Number.

Reorder Projects by Drag and Drop

Either click on the Project name in the Project Tree or on the Project within the timeline and drag it in the desired direction. The blue arrow defines where the Project will be located once you drop it.

Expand Project to show all levels and content

To view the Project in its entirety click on the expand arrows on each level.

Change order of Binders

The order of the Binders can be changed by:

  • Dragging and dropping the binder to the desired position as indicated by the blue arrow. The Binder can be dropped onto another Binder icon to make it become a Sub-Binder.
  • Clicking on the Binder icon to display the menu and select Reorder. Up and Down will move the binder one step up or down. First or Last will move the Binder to the top or the bottom.

4. Booking Operations

Bookings are the main element that build up the Project. When Bookings are added the Project will be visible in the time line and its length will continually be adjusted according to the dates of the added Project Bookings.

Bookings are in the level below Binders and can be made in the Long Form by highlighting a Time Range and dragging the desired Object/Objects directly in to the highlighted time from the Toolbox > Objects, from the Objects Tree, from the Personnel Tree, or from the Hourline View Selection.
Next, select the Project from the Project Selector drop-down. Note that if a Project is selected in the Tree, this will always appear at the very top of the Project Selector.



Bookings can be moved by dragging them into the calendar at the top and dropping them in the desired direction of the black arrows: if the arrows face to the right, the Booking will start on that day; if they are facing to the left, the Booking will end on that day.

This operation can also be executed with multiple Bookings at the same time. farmerswife will keep the Booking integrity and will move each Booking the correct number of days.

To Delete a Booking just drag and hover it over the Trash Can until it turns Red, then Drop. Multiple Bookings can be deleted in one go if they are multi selected on the left hand side and dragged to the Trash Can at the same time (unlike in the Hourline where only one Booking at a time can be deleted).

 

Any other Booking related operations can be done from the Booking Menu that appears when clicking on the Booking icon – See Hourline chapter for more details.

Did you find it helpful? Yes No